题目描述
Your task is to Calculate a + b.
输入
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
输出
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
样例输入
1 5
10 20
0 0
样例输出
6
30
大家帮帮忙呀!!一道C语言题:A+B for Input-Output Practice (III)
答案:3 悬赏:0 手机版
解决时间 2021-03-17 14:09
- 提问者网友:我是女神我骄傲
- 2021-03-16 14:30
最佳答案
- 五星知识达人网友:你哪知我潦倒为你
- 2021-03-16 16:06
#include <stdio.h>
main()
{
int a[100];
int b[100];
int c[100];
int i=0,j=0,k=0;
printf("请输入多个a与b的值,若无则输0 0\n");
scanf("%d %d",a,b);
c[0]=a[0]+b[0];
for(;c[k]!=0;)
{scanf("%d %d",&a[++i],&b[++j]);
c[++k]=a[i]+b[j];}
for(k=0;c[k]!=0;k++)
printf("a+b=%d\n",c[k]);
printf("感谢使用本系统!\n");
}
给你个建议,以后最好不要发英文,一般人懒得看的……
main()
{
int a[100];
int b[100];
int c[100];
int i=0,j=0,k=0;
printf("请输入多个a与b的值,若无则输0 0\n");
scanf("%d %d",a,b);
c[0]=a[0]+b[0];
for(;c[k]!=0;)
{scanf("%d %d",&a[++i],&b[++j]);
c[++k]=a[i]+b[j];}
for(k=0;c[k]!=0;k++)
printf("a+b=%d\n",c[k]);
printf("感谢使用本系统!\n");
}
给你个建议,以后最好不要发英文,一般人懒得看的……
全部回答
- 1楼网友:渡鹤影
- 2021-03-16 16:47
#include <stdio.h>
int main()
{
int a,b ;
while(scanf("%d %d",&a,&b))
{
if (a==0&&b==0) break;
printf("%d\n",a+b);
}
return 0;
}
- 2楼网友:思契十里
- 2021-03-16 16:41
scanf("%d %d",a,b);这句错了。
应该是 scanf("%d %d",&a,&b);
我要举报
如以上问答信息为低俗、色情、不良、暴力、侵权、涉及违法等信息,可以点下面链接进行举报!
大家都在看
推荐资讯