描述
Given a positive integer N, you should output the most right digit of N^N.
输入
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
输出
For each test case, you should output the rightmost digit of N^N.
样例输入
2 3 4
样例输出
7 6
提示
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6 我的代码是 #include<stdio.h>
void main()
{long int x;
int n,i,d;
scanf("%d",&n);
for(i=0;i<n;i++)
{ scanf("%ld",&x);
d=x%10;
if(d==0||d==1||d==9) printf("%d\n",d);
else if(d==2) printf("4\n");
else if(d==3) printf("7\n");
else if(d==4||d==6||d==8) printf("6\n");
else printf("3\n");}
}
现在是WA,应该怎么修改啊?