永发信息网

Digit Generator

答案:1  悬赏:20  手机版
解决时间 2021-04-22 01:30

Problem
For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M . For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256. Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207. You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1N100, 000 .
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.
The following shows sample input and output for three test cases.
Sample Input 3 216 121 2005
Sample Output 198 0 1979

最佳答案
#include <iostream>
using namespace std;
int main()
{
int n,i,j,num,a,b,c,d;
cin >>n;
for(i=0;i<n;i++)
{
cin >>num;
b=9;
a=num;
while((num/10)>0)
{
b=b+9;
num=num/10;
}

for(j=(a-b);j<=a;j++)
{
c=j;
d=j;
while((d/10)>0)
{
c=c+d%10;
d=d/10;
}
c=c+d;

if(c==a)
{
cout<<j<<endl;
break;
}
if(c!=a && j==a)
cout<<0<<endl;
}
}
return 0;
}
我要举报
如以上问答信息为低俗、色情、不良、暴力、侵权、涉及违法等信息,可以点下面链接进行举报!
大家都在看
汕尾市城区步步高点读机在哪里有卖?
北京怎么申请劳动仲裁,交易猫仲裁 5分
000657怎么样?
快乐宝贝童车城在什么地方啊,我要过去处理事
胸部下垂怎么办
赛尔号60级派鲁基达怎么打阿克希亚
matlab7.0安装问题
09年6月毕业还能参加校园招聘吗?
我这配置可以玩永恒之塔吗
怎么看我家里宽带几M,,,,,,啊 ??
接头寨在什么地方啊,我要过去处理事情
兄弟的英文句子,需一些带有什么兄弟情谊的英
问问升到六级需要多少经验,谢谢.
求解数学!(详解)
WINDOWS系统里所有快捷键功能
推荐资讯
翻译下 (可以帮我改下 改掉要说明)简单点
劲舞团花多少钱成5星
肛门周围有点发炎,并有时有点痒,特别是走路
梦见小白龙是什么意思,梦见白龙飞向我啥意思
本人57级鬼7 5段了怎么升级不了图标?现在图
笔记本开机风扇就在转是怎么回事
挂卧室的诗句,描写欧式别墅房间的句子(越多
怎么寄东西到外地
彩虹岛游侠75级有什么稀有弓吗?
我的ping很高
DNF机械师刷图有多快
我不是黄钻用户,QQ牧场是否可以通过黄钻用户
正方形一边上任一点到这个正方形两条对角线的
阴历怎么看 ?