Problem
For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M . For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256. Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207. You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1N100, 000 .
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.
The following shows sample input and output for three test cases.
Sample Input 3 216 121 2005
Sample Output 198 0 1979
Digit Generator
答案:1 悬赏:20 手机版
解决时间 2021-04-22 01:30
- 提问者网友:趣果有间
- 2021-04-21 07:20
最佳答案
- 五星知识达人网友:夜余生
- 2021-04-21 08:51
#include <iostream>
using namespace std;
int main()
{
int n,i,j,num,a,b,c,d;
cin >>n;
for(i=0;i<n;i++)
{
cin >>num;
b=9;
a=num;
while((num/10)>0)
{
b=b+9;
num=num/10;
}
for(j=(a-b);j<=a;j++)
{
c=j;
d=j;
while((d/10)>0)
{
c=c+d%10;
d=d/10;
}
c=c+d;
if(c==a)
{
cout<<j<<endl;
break;
}
if(c!=a && j==a)
cout<<0<<endl;
}
}
return 0;
}
using namespace std;
int main()
{
int n,i,j,num,a,b,c,d;
cin >>n;
for(i=0;i<n;i++)
{
cin >>num;
b=9;
a=num;
while((num/10)>0)
{
b=b+9;
num=num/10;
}
for(j=(a-b);j<=a;j++)
{
c=j;
d=j;
while((d/10)>0)
{
c=c+d%10;
d=d/10;
}
c=c+d;
if(c==a)
{
cout<<j<<endl;
break;
}
if(c!=a && j==a)
cout<<0<<endl;
}
}
return 0;
}
我要举报
如以上问答信息为低俗、色情、不良、暴力、侵权、涉及违法等信息,可以点下面链接进行举报!
大家都在看
推荐资讯