交换机的配置命令
- 提问者网友:临风不自傲
- 2021-03-19 08:04
- 五星知识达人网友:山河有幸埋战骨
- 2021-03-19 09:11
switch(config)# hostname hostname
在基于CLI的交换机上设置主机名/系统名:
switch(enable) set system name name-string
2.在基于IOS的交换机上设置登录口令:
switch(config)# enable password level 1 password
在基于CLI的交换机上设置登录口令:
switch(enable) set password
switch(enable) set enalbepass
3.在基于IOS的交换机上设置远程访问:
switch(config)# interface vlan 1
switch(config-if)# ip address ip-address netmask
switch(config-if)# ip default-gateway ip-address
在基于CLI的交换机上设置远程访问:
switch(enable) set interface sc0 ip-address netmask broadcast-address
switch(enable) set interface sc0 vlan
switch(enable) set ip route default gateway
4.在基于IOS的交换机上启用和浏览CDP信息:
switch(config-if)# cdp enable
switch(config-if)# no cdp enable
为了查看Cisco邻接设备的CDP通告信息:
switch# show cdp interface [type modle/port]
switch# show cdp neighbors [type module/port] [detail]
在基于CLI的交换机上启用和浏览CDP信息:
switch(enable) set cdp {enable|disable} module/port
为了查看Cisco邻接设备的CDP通告信息:
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
5.基于IOS的交换机的端口描述:
switch(config-if)# description description-string
基于CLI的交换机的端口描述:
switch(enable)set port name module/number description-string
6.在基于IOS的交换机上设置端口速度:
switch(config-if)# speed{10|100|auto}
在基于CLI的交换机上设置端口速度:
switch(enable) set port speed moudle/number {10|100|auto}
switch(enable) set port speed moudle/number {4|16|auto}
7.在基于IOS的交换机上设置以太网的链路模式:
switch(config-if)# duplex {auto|full|half}
在基于CLI的交换机上设置以太网的链路模式:
switch(enable) set port duplex module/number {full|half}
8.在基于IOS的交换机上配置静态VLAN:
switch# vlan database
switch(vlan)# vlan vlan-num name vla
switch(vlan)# exit
switch# configure teriminal
switch(config)# interface interface module/number
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan vlan-num
switch(config-if)# end
在基于CLI的交换机上配置静态VLAN:
switch(enable) set vlan vlan-num [name name]
switch(enable) set vlan vlan-num mod-num/port-list
9. 在基于IOS的交换机上配置VLAN中继线:
switch(config)# interface interface mod/port
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk encapsulation {isl|dotlq}
switch(config-if)# switchport trunk allowed vlan remove vlan-list
switch(config-if)# switchport trunk allowed vlan add vlan-list
在基于CLI的交换机上配置VLAN中继线:
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
Vlan-range [isl|dotlq|dotl0|lane|negotiate]
10.在基于IOS的交换机上配置VTP管理域:
switch# vlan database
switch(vlan)# vtp domain domain-name
在基于CLI的交换机上配置VTP管理域:
switch(enable) set vtp [domain domain-name]
11.在基于IOS的交换机上配置VTP 模式:
switch# vlan database
switch(vlan)# vtp domain domain-name
switch(vlan)# vtp {sever|cilent|transparent}
switch(vlan)# vtp password password
在基于CLI的交换机上配置VTP 模式:
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
12. 在基于IOS的交换机上配置VTP版本:
switch# vlan database
switch(vlan)# vtp v2-mode
在基于CLI的交换机上配置VTP版本:
switch(enable) set vtp v2 enable
13. 在基于IOS的交换机上启动VTP剪裁:
switch# vlan database
switch(vlan)# vtp pruning
在基于CL I 的交换机上启动VTP剪裁:
switch(enable) set vtp pruning enable
14.在基于IOS的交换机上配置以太信道:
switch(config-if)# port group group-number [distribution {source|destination}]
在基于CLI的交换机上配置以太信道:
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
15.在基于IOS的交换机上调整根路径成本:
switch(config-if)# spanning-tree [vlan vlan-list] cost cost
在基于CLI的交换机上调整根路径成本:
switch(enable) set spantree portcost moudle/port cost
switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
16.在基于IOS的交换机上调整端口ID:
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
在基于CLI的交换机上调整端口ID:
switch(enable) set spantree portpri {mldule/port}priority
switch(enable) set spantree portvlanpri {module/port}priority [vlans]
17. 在基于IOS的交换机上修改STP时钟:
switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
switch(config)# spanning-tree [vlan vlan-list] max-age seconds
在基于CLI的交换机上修改STP时钟:
switch(enable) set spantree hello interval[vlan]
switch(enable) set spantree fwddelay delay [vlan]
switch(enable) set spantree maxage agingtiame[vlan]
18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:
switch(config-if)#spanning-tree portfast
在基于CLI的交换机端口上启用或禁用Port Fast 特征:
switch(enable) set spantree portfast {module/port}{enable|disable}
19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
在基于CLI的交换机端口上启用或禁用UplinkFast 特征:
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name cv
- 1楼网友:愁杀梦里人
- 2021-03-19 09:17
交换机命令 ~~~~~~~~~~ [quidway]super password 修改特权用户密码 [quidway]sysname 交换机命名 [quidway]interface ethernet 0/1 进入接口视图 [quidway]interface vlan x 进入接口视图 [quidway-vlan-interfacex]ip address 10.65.1.1 255.255.0.0 [quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 静态路由=网关
[quidway]user-interface vty 0 4 [s3026-ui-vty0-4]authentication-mode password [s3026-ui-vty0-4]set authentication-mode password simple 222 [s3026-ui-vty0-4]user privilege level 3
[quidway-ethernet0/1]duplex {half|full|auto} 配置端口双工工作状态 [quidway-ethernet0/1]speed {10|100|auto} 配置端口工作速率 [quidway-ethernet0/1]flow-control 配置端口流控 [quidway-ethernet0/1]mdi {across|auto|normal} 配置端口mdi/mdix状态平接或扭接 [quidway-ethernet0/1]port link-type {trunk|access|hybrid} 设置接口工作模式 [quidway-ethernet0/1]shutdown 关闭/重起接口 [quidway-ethernet0/2]quit 退出系统视图
[quidway]vlan 3 创建/删除一个vlan/进入vlan模式 [quidway-vlan3]port ethernet 0/1 to ethernet 0/4 在当前vlan增加/删除以太网接口 [quidway-ethernet0/2]port access vlan 3 将当前接口加入到指定vlan [quidway-ethernet0/2]port trunk permit vlan {id|all} 设trunk允许的vlan [quidway-ethernet0/2]port trunk pvid vlan 3 设置trunk端口的pvid
[quidway]monitor-port <interface_type interface_num> 指定和清除镜像端口 [quidway]port mirror <interface_type interface_num> 指定和清除被镜像端口 [quidway]port mirror int_list observing-port int_type int_num 指定镜像和被镜像
[quidway]description string 指定vlan描述字符 [quidway]description 删除vlan描述字符 [quidway]display vlan [vlan_id] 查看vlan设置
[quidway]stp {enable|disable} 开启/关闭生成树,默认关闭 [quidway]stp priority 4096 设置交换机的优先级 [quidway]stp root {primary|secondary} 设置交换机为根或根的备份 [quidway-ethernet0/1]stp cost 200 设置交换机端口的花费
[switcha-vlanx]isolate-user-vlan enable 设置主vlan [switcha]isolate-user-vlan <x> secondary <list> 设置主vlan包括的子vlan [quidway-ethernet0/2]port hybrid pvid vlan <id> 设置vlan的pvid [quidway-ethernet0/2]port hybrid pvid 删除vlan的pvid [quidway-ethernet0/2]port hybrid vlan vlan_id_list untagged 设置无标识的vlan 如果包的vlan id与pvid一致,则去掉vlan信息. 默认pvid=1。 所以设置pvid为所属vlan id, 设置可以互通的vlan为untagged. ---------------------------------------- 路由器命令 ~~~~~~~~~~ [quidway]display version 显示版本信息 [quidway]display current-configuration 显示当前配置 [quidway]display interfaces 显示接口信息 [quidway]display ip route 显示路由信息
[quidway]sysname aabbcc 更改主机名 [quidway]super passwrod 123456 设置口令 [quidway]interface serial0 进入接口 [quidway-serial0]ip address <ip><mask> [quidway-serial0]undo shutdown 激活端口 [quidway]link-protocol hdlc 绑定hdlc协议 [quidway]user-interface vty 0 4 [quidway-ui-vty0-4]authentication-mode password [quidway-ui-vty0-4]set authentication-mode password simple 222 [quidway-ui-vty0-4]user privilege level 3 [quidway-ui-vty0-4]quit [quidway]debugging hdlc all serial0 显示所有信息 [quidway]debugging hdlc event serial0 调试事件信息 [quidway]debugging hdlc packet serial0 显示包的信息