题目内容:
已知某种铅密度为11340kg/m3 ,求输入球的直径(厘米数),求铅球有多少kg。
输入格式:
仅仅一个小数
输出格式:
仅仅一个小数
输入样例:
9.8
输出样例:
5.588431
时间限制:500ms内存限制:32000kb
已知某种铅密度为11340kg/m3 ,求输入球的直径(厘米数),求铅球有多少kg。
答案:1 悬赏:30 手机版
解决时间 2021-03-01 07:39
- 提问者网友:活着好累
- 2021-02-28 07:08
最佳答案
- 五星知识达人网友:夜余生
- 2021-02-28 07:46
#include "stdio.h"
int main(void){
double d;
while(1){
printf("Please enter the diameter of the shot(cm)...\nd=");
if(scanf("%lf",&d) && d>=0.0){
printf("%f\n",0.01134*3.1415926/3*4*d*d*d/8);
break;
}
printf("Error, must be x>=0: ");
fflush(stdin);
}
return 0;
}
int main(void){
double d;
while(1){
printf("Please enter the diameter of the shot(cm)...\nd=");
if(scanf("%lf",&d) && d>=0.0){
printf("%f\n",0.01134*3.1415926/3*4*d*d*d/8);
break;
}
printf("Error, must be x>=0: ");
fflush(stdin);
}
return 0;
}
我要举报
如以上问答信息为低俗、色情、不良、暴力、侵权、涉及违法等信息,可以点下面链接进行举报!
大家都在看
推荐资讯